Download! Download eBook tingkat SMP, SMA, & SMK

Perbedaan Konfigurasi DHCP pada Router Cisco dan MikroTik

DHCP (Dynamic Host Configuration Protocol) Server merupakan salah satu layanan server yang dapat memberikan alamat IP kepada komputer client secara otomatis tanpa harus melakukan konfigurasi manual. Untuk mendapatkan alamat IP yang tersedia pada server, setiap komputer client cukup mengaktifkan pengaturan DHCP client yang dengan memilih “Obtain an IP address automatically” pada konfigurasi Network and Sharing Center (khusus sistem operasi Windows). Dengan layanan DHCP server dapat menghemat waktu jika banyak komputer client yang terhubung ke dalam jaringan.

Pada tutorial kali ini, kita akan mencoba membahas konfigurasi DHCP Server pada perangkat router Cisco menggunakan aplikasi simulasi Cisco Packet Tracer dan MikroTik RouterOS yang diinstall pada VirtualBox.

Baca juga:

Konfigurasi DHCP pada Router Cisco

1. Topologi Jaringan

Konfigurasi DHCP Server pada router Cisco

2. Konfigurasi interface fa4/0

Tambahkan alamat IP 192.168.137.1 dengan subnet mask 255.255.255.0 pada interface fa4/0 seperti berikut ini:

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname DHCP-SERVER
DHCP-SERVER(config)#int fa4/0
DHCP-SERVER(config-if)#ip address 192.168.137.1 255.255.255.0
DHCP-SERVER(config-if)#no shutdown

3. Konfigurasi DHCP

Lanjutkan dengan konfigurasi DHCP Server, default gateway dan dns server pada router dengan perintah berikut:

DHCP-SERVER#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DHCP-SERVER(config)#ip dhcp excluded-address 192.168.137.1
DHCP-SERVER(config)#ip dhcp pool LAN-POOL-1
DHCP-SERVER(dhcp-config)#network 192.168.137.0 255.255.255.0
DHCP-SERVER(dhcp-config)#default-router 192.168.137.1
DHCP-SERVER(dhcp-config)#dns-server 192.168.137.1

Keterangan:

  • excluded-address : untuk menentukan IP address yang tidak boleh di lease oleh DHCP, biasanya berupa IP static untuk server / printer
  • pool : tentukan nama pool DHCP, misal untuk network 192.168.137.0 namanya LAN-POOL-1
  • network : menentukan alamat network DHCP
  • default-router : menentukan default gateway untuk klien
  • dns-server : menentukan dns server untuk klien

4. Cek IP Address pada Komputer PC

Untuk mengetahui apakah konfigurasi DHCP server pada router telah berhasil, dapat dilakukan dengan cara mengecek satu-persatu alamat IP pada masing-masing PC, dengan cara klik icon PC > Desktop > IP Configuration > pilih DHCP, tunggu beberapa saat sampai muncul alamat IP, seperti gambar berikut.

Konfigurasi dhcp server pada router cisco
IP Address pada PC0
Konfigurasi dhcp server pada router cisco
IP Address pada PC1
Konfigurasi dhcp server pada router cisco
IP Address pada PC3
Konfigurasi dhcp server pada router cisco
IP Address pada PC3

Konfigurasi DHCP pada MikroTik RouterOS

1. Persiapan

Sebelum melakukan konfigurasi DHCP Server pada MikroTik, perlu dipersiapkan beberapa software berikut ini:

  • Software yang perlu dipersiapkan:
    • File ISO Microsoft Windows (pada contoh ini menggunakan Windows XP), digunakan sebagai komputer guest (DHCP client)
    • File ISO MikroTik RouterOS
    • Sofware VirtualBox
  • Instalasi:
    • Untuk memastikan konfigurasi DHCP Server pada MikroTik berhasil, perlu dua komputer Guest yang bertindak sebagai komputer client. Untuk itu, install dua komputer guest pada VirtualBox menggunakan sistem Operasi Windows apa saja
    • Atur konfigurasi jaringan dengan cara klik icon Gear (warna Orange) > Network > Adapter 1 > Centang Enable Network Adapter > Attachment to pilih Internal Network
    • Install MikroTik RouterOS pada VirtualBox, login dengan user admin dan password dikosongkan

2. Topologi

Konfigurasi DHCP Server pada Mikrotik RouterOS

3. Konfigurasi

#1 Menambahkan IP Address 192.168.137.1/24 pada salah satu interface yang akan digunakan untuk jaringan LAN, (misalnya interface ether2) dengan perintah berikut:

[admin@MikroTik] >ip address add address=192.168.137.1/24 interface=ether2

Cek konfigurasi IP Address pada ether2 apakah sudah berhasil atau belum dengan perintah berikut:

[admin@MikroTik] >ip address print
Konfigurasi DHCP Server pada Mikrotik RouterOS

#2 Konfigurasi DHCP Server yang nantinya akan digunakan sebagai alamat IP komputer client, dengan range IP 192.168.137.2-192.168.137.254 seperti berikut ini:

[admin@MikroTik] >ip pool
[admin@MikroTik] /ip pool>add name=dhcp-pool0 range=192.168.137.2-192.168.137.254

Cek hasil konfigurasi DHCP Server dengan perintah berikut:

[admin@MikroTik] /ip pool>print
Konfigurasi DHCP Server pada Mikrotik RouterOS

#3 Konfigurasi alamat network (Net Id) dan gateway, dengan perintah berikut:

[admin@MikroTik] >ip dhcp-server network
[admin@MikroTik] /ip dhcp-server network>add address=192.168.137.0/24 gateway=192.168.137.1

Cek konfigurasi Network Id dan gateway dengan perintah:

[admin@MikroTik] /ip dhcp-server network>print
Konfigurasi DHCP Server pada Mikrotik RouterOS

#4 Hubungkan interface ether2 dengan dhcp-pool0 yang sudah dikonfigurasi sebelumnya dengan perintah:

[admin@MikroTik] > ip dhcp-server
[admin@MikroTik] /ip dhcp-server>add interface=ether2 address-pool=dhcp-pool0
Konfigurasi DHCP Server pada Mikrotik RouterOS

#5 Tanda X menandakan bahwa dhcp-pool0 belum aktif, sehingga harus diaktifkan terlebih dahulu dengan perintah:

[admin@MikroTik] /ip dhcp-server>enable 0
Konfigurasi DHCP Server pada Mikrotik RouterOS

4. Cek IP Address pada komputer guest (Windows XP)

Untuk mengetahui apakah konfigurasi DHCP Server pada Mikrotik berhasil, maka lakukan pengecekan alamat IP dengan cara buka Control Panel > Network and Internet Connections > Network Connections > Local Area Network > Klik kanan pilih Status, atau cek di command prompt dengan perintah ipconfig.

Konfigurasi DHCP Server pada Mikrotik RouterOS
Komputer PC0
Konfigurasi DHCP Server pada Mikrotik RouterOS

Karena PC0 terhubung ke Server MikrotikOS pertama kali, maka komputer tersebut mendapatkan alamat IP 192.168.137.2 disusul komputer PC1 dengan alamat IP 192.168.137.3, sedangkan alamat IP 192.168.137.1 merupakan alamat interface ether2.

5. Uji Konektivitas

Untuk mengetahui apakah Mikrotik terhubung ke komputer client, dapat dilakukan uji konektivitas dengan perintah ping seperti gambar berikut.

Konfigurasi DHCP Server pada Mikrotik RouterOS

Jika hasil uji ping yang diperoleh tidak seperti gambar di atas atau status Request Timeout, matikan pengaturan Windows Firewall pada komputer guest, lakukan ping ulang seperti cara sebelumnya.

Thumbnail: Infographic vector created by macrovector_official – www.freepik.com

206 total views, 5 views today

Leave a Reply