Konfigurasi Routing Information Protocol (RIP) pada Cisco Packet Tracer

Dynamic Routing Protocol

Pada postingan sebelumnya, telah kami bahas tentang konfigurasi Static Routing menggunakan 4 (empat) router pada aplikasi Cisco Packet Tracer yang dapat di simak di sini.

Dalam sebuah network dimana terdapat jalur routing lebih dari satu rute untuk mencapai tujuan yang sama biasanya menggunakan dynamic routing. Beda halnya dengan static routing, dynamic routing lebih tepat diimplementasikan pada network besar yang terdapat lebih dari 3 gateway. Dynamic routing menggunakan protocol routing dalam pembentukan tabel routing. Ketika topologi jaringan berubah, tabel routing akan ikut berubah secara otomatis. Salah satu Dynamic Routing Protocol adalah Routing Information Protocol (RIP).

Pembagian Dynamic Routing Protocol dapat dilihat pada diagram berikut ini.

Pembagian dynamic routing protocol

Baca juga:

Routing Information Protocol (RIP)

Routing Information Protocol (RIP) merupakan protokol routing yang paling umum dijumpai karena sudah termasuk dalam sebuah sistem operasi seperti UNIX atau Novell. RIP menggunakan metode Algoritma Routing Distance Vector . Algoritma ini bekerja secara berkala dengan menyalin table routing dari router ke router. Perubahan table routing di update antar router yang saling berhubungan saat terjadi perubahan topologi.

Topologi

Topologi routing information protocol (RIP)

Konfigurasi Routing

Lakukan konfigurasi pada perangkat dan/ interface berikut:

  1. Konfigurasi IP Address pada PC
  2. Konfigurasi interface pada FastEthernet0/0 dan Serial
  3. Konfigurasi RIP pada masing-masing router

1. Konfigurasi IP Address pada PC

PC0PC1PC2PC3
IP Address192.168.10.2192.168.20.2192.168.30.2192.168.40.2
Netmask255.255.255.0255.255.255.0255.255.255.0255.255.255.0
Gateway192.168.10.1192.168.20.1192.168.30.1192.168.40.1

2. Konfigurasi IP Address pada interface FastEthernet dan Serial

Pontianak: Router0

  • Interface FastEthernet0/0 pada Router0, IP Address 192.168.10.1, Subnet Mask 255.255.255.0
  • Interface Serial2/0 terhubung ke Router1, IP Address 192.168.1.1, Subnet Mask 255.255.255.0
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se2/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Cek status IP Address interface pada Router0:

Router#show ip interface brief
Interface              IP-Address      OK? Method Status            Protocol
FastEthernet0/0        192.168.10.1    YES manual up                up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              192.168.1.1     YES manual down                 down
Serial3/0              unassigned      YES unset  administratively down down
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down
Router#

Sanggau: Router1

  • Interface FastEthernet0/0 pada Router1, IP Address 192.168.20.1, Subnet Mask 255.255.255.0
  • Interface Serial2/0 terhubung ke Router0, IP Address 192.168.1.2, Subnet Mask 255.255.255.0
  • Interface Serial3/0 terhubung ke Router2, IP Address 192.168.2.1, Subnet Mask 255.255.255.0
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se2/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int se3/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown

Cek status IP Address interface pada Router1:

Router#show ip interface brief
Interface              IP-Address      OK? Method Status            Protocol
FastEthernet0/0        192.168.20.1    YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              192.168.1.2     YES manual up                    up
Serial3/0              192.168.2.1     YES manual up                    up
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down
Router#

Sintang: Router2

  • Interface FastEthernet0/0 pada Router2, IP Address 192.168.30.1, Subnet Mask 255.255.255.0
  • Interface Serial2/0 terhubung ke Router2, IP Address 192.168.2.2, Subnet Mask 255.255.255.0
  • Interface Serial3/0 terhubung ke Router3, IP Address 192.168.3.1, Subnet Mask 255.255.255.0
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.30.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se2/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int se3/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown

Cek status IP Address interface pada Router2:

Router#show ip interface brief
Interface              IP-Address      OK? Method Status            Protocol
FastEthernet0/0        192.168.30.1    YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              192.168.2.2     YES manual up                    up
Serial3/0              192.168.3.1     YES manual down                  down
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down
Router#

Putussibau: Router3

  • Interface FastEthernet0/0 pada Router2, IP Address 192.168.40.1, Subnet Mask 255.255.255.0
  • Interface Serial2/0 terhubung ke Router2, IP Address 192.168.3.2, Subnet Mask 255.255.255.0
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.40.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se2/0
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown

Cek status IP Address interface pada Router3:

Router#show ip interface brief
Interface              IP-Address      OK? Method Status            Protocol
FastEthernet0/0        192.168.40.1    YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              192.168.3.2     YES manual up                    up
Serial3/0              unassigned      YES unset  administratively down down
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down
Router#

3. Konfigurasi RIP pada masing-masing router

Pontianak: Router0

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.10.0
Router(config-router)#network 192.168.1.0
Router(config-router)#no auto-summary

Sanggau: Router1

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.20.0
Router(config-router)#no auto-summary

Sintang: Router2

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.30.0
Router(config-router)#no auto-summary

Putussibau: Router3

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.40.0
Router(config-router)#no auto-summary

Cek Tabel Routing

Router0

Router(config)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial2/0
R    192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:14, Serial2/0
R    192.168.3.0/24 [120/2] via 192.168.1.2, 00:00:14, Serial2/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0
R    192.168.20.0/24 [120/1] via 192.168.1.2, 00:00:14, Serial2/0
R    192.168.30.0/24 [120/2] via 192.168.1.2, 00:00:14, Serial2/0
R    192.168.40.0/24 [120/3] via 192.168.1.2, 00:00:14, Serial2/0
Router(config)#

Router1

Router(config)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial2/0
C    192.168.2.0/24 is directly connected, Serial3/0
R    192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:06, Serial3/0
R    192.168.10.0/24 [120/1] via 192.168.1.1, 00:00:10, Serial2/0
C    192.168.20.0/24 is directly connected, FastEthernet0/0
R    192.168.30.0/24 [120/1] via 192.168.2.2, 00:00:06, Serial3/0
R    192.168.40.0/24 [120/2] via 192.168.2.2, 00:00:06, Serial3/0
Router(config)#

Router2

Router(config)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:26, Serial2/0
C    192.168.2.0/24 is directly connected, Serial2/0
C    192.168.3.0/24 is directly connected, Serial3/0
R    192.168.10.0/24 [120/2] via 192.168.2.1, 00:00:26, Serial2/0
R    192.168.20.0/24 [120/1] via 192.168.2.1, 00:00:26, Serial2/0
C    192.168.30.0/24 is directly connected, FastEthernet0/0
R    192.168.40.0/24 [120/1] via 192.168.3.2, 00:00:27, Serial3/0
Router(config)#

Router3

Router(config)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.1.0/24 [120/2] via 192.168.3.1, 00:00:08, Serial2/0
R    192.168.2.0/24 [120/1] via 192.168.3.1, 00:00:08, Serial2/0
C    192.168.3.0/24 is directly connected, Serial2/0
R    192.168.10.0/24 [120/3] via 192.168.3.1, 00:00:08, Serial2/0
R    192.168.20.0/24 [120/2] via 192.168.3.1, 00:00:08, Serial2/0
R    192.168.30.0/24 [120/1] via 192.168.3.1, 00:00:08, Serial2/0
C    192.168.40.0/24 is directly connected, FastEthernet0/0
Router(config)#

Referensi:

Leave a Reply